Skip to main content

PHP 8.0 or 8.1

Comments

7 comments

  • KC George

    Hi Antonio,

    My test websites use PHP 8.0.24, as I explain to you in this video https://jmp.sh/ufyGnu6. There are no known compatibility issues between Brizy and PHP versions 8.0 and higher. 

    1. https://kctest.online/
    2. https://woo.kctest.online/

    I don't anticipate any issue if your hosting server gets upgraded to PHP 8.0 or 8.1.

    0
  • Terry Russell

    I am running PHP-FPM 8.0.20 at https://recallinsider.com and Brizy works fine for me.

    0
  • Sebastian Korybski

    Not so fast, Gorge :). Maybe is working on Apache servers but on LiteSpeed servers doesn't work. In future, please make test on different Linux machines. On LiteSpeed serwers and PHP 8, page builder shows errors, for example:

    Warning: Attempt to read property "ID" on null in public_html/wp-content/plugins/brizy/admin/main.php on line 133

    Warning: Attempt to read property "post_status" on null in /public_html/wp-admin/includes/template.php on line 2197

    Warning: Attempt to read property "ID" on null in public_html/wp-admin/includes/template.php on line 2215

    I agree with you, on frontend works fine on both systems, but on backend not so much.

    0
  • Brooke .

    > There are no known compatibility issues between Brizy and PHP versions 8.0 and higher.

    I am running PHP 8.1 on a site, and while there are no FATAL errors there are quite a few deprecation WARNINGS these should be addressed as some may become fatals errors in PHP 8.2 and it just keeps the error logging cleaner and follows PHP/WordPress best practices. Here are the two main offenders

     

    ```

    trim(): Passing null to parameter #1 ($string) of type string is deprecated

    • wp-content/plugins/brizy/editor.php:52

    preg_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated

    • wp-content/plugins/brizy/editor/url-builder.php:456

    ```

    Looking forward to these warnings being addressed in future updates

     

     

    0
  • KC George

    Hi Brooke,

    Thanks for sharing this. We will look into this warning.

    I was checking the error log at my end. I am on PHP 8.0.25. Here is my debug log. https://brizytest.online/wp-content/debug.log  It shows 2 PHP warnings.

    [05-Nov-2022 13:10:08 UTC] PHP Warning:  Undefined property: stdClass::$uploads in /homepages/25/d937416670/htdocs/clickandbuilds/Homi/wp-content/plugins/brizy/admin/cloud/block-bridge.php on line 41
    [05-Nov-2022 13:10:08 UTC] PHP Warning:  foreach() argument must be of type array|object, null given in /homepages/25/d937416670/htdocs/clickandbuilds/Homi/wp-content/plugins/brizy/admin/cloud/block-bridge.php on line 41
    0
  • Brooke .

    Yeah, I run PHP 8.0.x in Production and 8.1.x in development. Looking at the upgrading log on PHP.net I think the errors are coming from:

    • Passing null to non-nullable parameters of built-in functions

    • Implementing Serializable without __serialize() and __unserialize()

    being deprecated: https://www.php.net/manual/en/migration81.deprecated.php

     

    Like I mentioned previously, Brizy does "work" with PHP 8 and 8.1 but not without warnings. With 7.4 being at end of life at the end of this month and 8.2 right around the corner, I'm looking forward to Brizy continuing to evolve.

    0
  • KC George

    Thank you Brooke for sharing additional information. I have escalated this to our development team. 

    0

Please sign in to leave a comment.