Skip to main content

Native Pop Up Redirect Not Working

Comments

31 comments

  • Sandra Prunici

    Hi Geoff,

    Could you please describe how did you create the pop-up and how did you add the redirect? What elements did you add? Did you use a simple pop-up to an element or a global pop-up?
    Could you please add it again to check it? You can create a test page and add it to this page.

    Thanks!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Dear Sandra

    I have attached some screenshots. It is a simple template pop up where I have changed the pic and text and just added a url redirect in another browser. The pop up works perfectly but will redirect back to the same page with a hash on the end of the web page. It has not been set as global (should it be).

    You will also notice that any form of pop up on Brizy leaves you no room to work on it because it drops off the screen

     

    Geoff

     

    0
  • Sandra Prunici

    I tried to reproduce this problem but I can't find it any in the global pop-up or in the simple pop-up. See this screen record https://jumpshare.com/v/Sw9P7a5rY9xLScbjMtg7
    Could you try to delete the site cache? Or could you send to us the URL link of the page is set this pop-up (and please indicate where I can find it) to check it?
    Thanks!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Sandra the pop up is on www.neuro-performance.co.uk after 10 seconds and if you select the button it will not redirect anywhere

    Geoff

    0
  • Geoffrey Greenwood

    This is the redirect

     

    https://emailoctopus.com/lists/f12b8878-53f5-11ea-a3d0-06b4694bee2a/forms/subscribe

    0
  • Sandra Prunici

    I suppose that there can be a cache problem. Could you please delete the cache from the site?
    Also, could you try to recreate this button?

    Thanks!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Hi Sandra 

    Cleared the cache a couple of times and tried in different browsers (Incognito and open) still nothing. Deleted it all tried again and still will not redirect. Could you try a pop up using the same template and add my redirect url?

    Best Regards

     

    Geoff

     

    0
  • Sandra Prunici

    I don't know what template did you use, but I added the link you provided and all seems to work fine. See here https://jumpshare.com/v/KaIxZuv99tp4HTgJffG7

    Maybe you have another global pop-up with the same template and conditions. Could you check this, please? I checked the button of the pop-up and I don't find any link added to it.

    Thanks!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Hi Sandra

    The first template here on the right of the blank template. Could it be the template?

     

    Kindest

     

    Geoff

    0
  • Sandra Prunici

    Yes, I used this template for my pop-up and all worked fine, as you could see from the screen record.
    Did you check if you have another global pop-up with the same view and conditions?

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Sandra I think that you used the 2nd one (the blue one in your video) and not the first one that I used. 

    Thoughts?

     

    Geoff

    0
  • Geoffrey Greenwood

    0
  • Sandra Prunici

    Hi Geoff,

    The used template doesn't have any importance in this situation. I created a new blank global pop-up and added the link you share to us and all worked fine https://jumpshare.com/v/iulT3FPwMxGk415IqbEQ I also tried to change the link and all worked fine. 

    Did you check if you have another global pop-up with the same view and conditions?

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    HI Sandra

    Good morning.

    I have used your template which is an email capture and then a success redirect and works perfectly for me so you are right there. However, I think that you may be wrong with the templates that use a button for a redirect without any email capture. I have now tried 2 different ones and they do not redirect to where you want to go. They just loop back to the original web page.

    Please try the template that I have used and I think you will discover a problem. Also any progress on the settings dropping off the page when entering info as shown in my screenshot?

     

    Kindest

     

    Geoff

    0
  • Sandra Prunici

    Yes, I tried also the template you used and all seems to work fine.
    See here - https://jumpshare.com/v/v0KMsopnDAiRAKYDv4kW
    Also, I tied the Incognito browser - https://jumpshare.com/v/sbXmrnGVnbGSRlOD6FXl

    Regarding this "Also any progress on the settings dropping off the page when entering info as shown in my screenshot?" - could you give please more details?

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Hi Sandra

    I can see your example but I cannot see the incognito link it is not working. I am at a loss as to what setting is not working then for me. I will keep looking.

    As regards the settings dropping off the screen I attach screenshot again: It makes it impossible to get at all the settings.

     

    Kindest

     

    Geoff

    0
  • Geoffrey Greenwood

    Sandra

    I have tried every option to no avail. It will not redirect and it loops back to the original page with a hash on the end of the url. Can you see what causes that. I do have a pop up video on the home page could that be causing the problem? Please look at www.neuro-performance.co.uk

    https://www.neuro-performance.co.uk/resources# 

     

    Kindest

     

    Geoff

     

    0
  • Sandra Prunici

    I updated the screen record and all should work fine https://jumpshare.com/v/sbXmrnGVnbGSRlOD6FXl Try checking again the URL link. Also, try to check if you don't have another global pop-up with the same design and with a wrong URL.

    For the second problem - we knew about it, but we already fixed it in one of previous updates, could you please check if you have the latest Brizy Free (1.0.126) and Pro (0.0.41) versions?

    Thanks!

    Best regards,
    Sandra

     

    0
  • Geoffrey Greenwood

    Hi Sandra

    I am wondering if there is a slight mis-communication here between us: Let me re-iterate just in case:

    1. The screen issue is not fixed for me as I am on Brizy Cloud as a lifetime Appsumo member.

    2. My pop us is not created on page on a button but through the trigger and action pop up system where the visitor does nothing and the system takes over the pop up reveal.

    Is this where our problem can be found? I have adjusted every setting option as well as watched the videos in your youTube channel.

     

    Kindest

     

    Geoff

    0
  • Sandra Prunici

    I'm sorry for this inconvenience. These days we had a lot of tickets and I forget that you encounter this problem on Brizy Cloud. I already created an issue for our team and they will investigate this problem.
    Thanks for reporting this!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Thanks Sandra

    I look forward to hearing from you.

     

    Kindest

     

    Geoff

    0
  • Sandra Prunici

    Thank you too! Yes, I will keep you updated regarding this problem!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Hi Sandra

    Is there any progress on these 2 problems surrounding native pop ups in Brizy Cloud? 

    I am really desperate to move on.

     

    Look forward to hearing from you

     

    Geoff

    0
  • Sandra Prunici

    Hi Geoff,

    Our team are investigating this issue and are finding a solution to this problem. When I will receive a notification from our developers on this issue, I will inform you here regarding this.

    Thanks!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Hi Sandra

    Please can you advise the progress being made on this issue. This has now gone on over 2 weeks and must be a simple fix. 

    Can I assume that it is not being given any priority?

    I would like to know what the problem is considering that that your pop ups were rolled out across all your products?

    I will await your response again.

     

    Kindest

     

    Geoff

    0
  • Sandra Prunici

    Hi,

    Our developers are still working on this issue. Soon I will have a certain response from our team and then I will inform you too.

    Thanks!

    0
  • Geoffrey Greenwood

    Thank you Sandra I look forward to hearing from you as soon as you can.

     

    Kindest

     

    Geoff

    0
  • Geoffrey Greenwood

    Hi Sandra

    Please can you ask the developers where they are up to with this problem? It seems strange considering that the pop ups were part of a release and they do not work on just simple redirection.

    This has been over a month now and I am wondering if it is not being worked upon at all?

    Please can you come back to me asap.

     

    Thank you

     

    Geoff

    0
  • Sandra Prunici

    Hi,

    We are still working on this problem. Our developers are working on it. When I will receive a notification from them, I will inform you too!

    Thank you for understanding!

    Best regards,
    Sandra

    0
  • Geoffrey Greenwood

    Hello Sandra

    Please tell me that these errors have now been overcome? Hope to hear from you very soon.

     

    Kindest

     

    Geoff

    0

Please sign in to leave a comment.