Skip to main content

Brizy icons not displaying

Comments

36 comments

  • Mourier Stéphane
     
     
    Hello,
    I have had exactly the same problem since the last two versions.
    When I go back to the free version 1.0112. More problems
    2
  • Malachi Gross

    I'm starting to look like a fool with my client because of these icons not working. I've tried on both Windows and Mac, on all varieties of browsers: Firefox, Safari, Chrome, Edge, DuckDuckGo Browser, Dolphin, Puffin, and even Opera. They just dont show up on the live site. They're there in the editor all day, every day - always have been - but not my live sites. My client wants these icons and I'm starting to look like a novice because they're not working.

    2
  • Fin Goulding

    Thanks Stuart, but somehow I don't think that Godaddy is going to listen to me....

    2
  • Stuart Longcroft

    Same here, just started happening with latest update.

    I get a '403 (Forbidden)' error.

    All files and folder permissions as expected, switched off all plugins.

    1
  • Mourier Stéphane

    As soon as I put back an old version 1.0.103 everything works again.
    I even set the default theme with all plugins disabled and it doesn't work.
    The problem comes from the latest version
     
    1
  • Mourier Stéphane

    They will find ...
    It is true that it is not easy when we have production sites.
    I also have a problem with launching videos in a slider with the latest version

     

    1
  • Stuart Longcroft

    My video slider is Ok... for now!

    Hopefully they'll sort it quickly!

    1
  • Mourier Stéphane

    Me the video no longer starts in slideshow mode, I have the right to a blank page ... and as soon as I go back in version, it works

     

    1
  • Marco Michely

    Dear Brizy Team. Please think again about if it is a good idea to deliver icons in .txt format. There will be problems with this on some hosting companies. Many support requests will be made to you. Maybe you decide to prevent this.

    1
  • James Sowers

    The SVG Icons as TXT files are not working... They are there in the layout (Invisible), but they do not show up. Almost about to give up completely on this page builder and just call it a total loss, so buggy, not mobile design-friendly in the least bit.

    1
  • George L Peters Jr

    OK so Brizy team, Hello are you there? It is now coming up on a full day and you have not chimed in. Can you at least acknowledge the problem and say "we're working on it" or "we are aware of the issue" 'cause i paid you good money for a set of working features that I have not received. Just saying. Communication is king. 

    0
  • Dimi from Brizy

    Hey guys, sorry for the late reply, Natalia will look into it. I know there was an issue that was addressed regarding the icons and how they are delivered. 

    She'll reply about this. 

    We are also putting an update together this week. We'll start a beta for it. If there is something to fix on our side we'll fix it for sure. 

    It seems that this issue affects only some server configurations we'll need to look into it. I've tested it in the office on all the installs we have on the latest version and they seem to work fine: https://jmp.sh/FxOOWoS

    Let me get Natalia on this. 

    Please accept my apologies for the inconvenience and thanks for your patience. 

    0
  • Stuart Longcroft

    Hi all,

    Quick update from me, I have been giving Natalia a hard time about this on a support ticket, however it isn't a Brizy issue per se.

    Brizy has changed the way they display their icons (via txt files now I think?) but that shouldn't in and of itself be an issue.  The issue I had with icons not showing was actually caused by WPMU's Defender Plugin, it has some pretty restrictive settings and had set txt files to 'secure' and not allowing access to them.

    Deactivating Defender was not enough, I had to go into the .htaccess file and remove some code that it had put in there too.

    My icons now show.

    So whilst Brizy did change something, it was actually Defender causing my issues.

    Hope that helps someone.

    0
  • Stuart Longcroft

    When you disable the WPMU Defender plugin, it does not remove the code from the .htaccess file that it creates.

    So whilst the plugin was deactivated, the .htaccess file was still blocking what Defender had told it to block.  An issue with Defender here, not Brizy.

    Link to Defender here:  https://premium.wpmudev.org/project/wp-defender/

    0
  • Natalia Chitoroaga

    Thanks, Stuart for letting us know.

    This is why I had 403, I could not see the wpmu plugins in your server. 

    I've just added this comment to our internal issue for the 403 error type. 

     

    Regards, Natalia

    0
  • Mourier Stéphane

    Hello,

    Problem fixed This is the HIDE MY WP plugin which posed the problem because even deactivating the Bug still occurred.

    I reset the settings and everything works.

    Do you know a plugin to hide plugins from its site that is compatible with brizy

    Thank you

    0
  • Don Schaffer

    I had a ThemeFuse theme installed, which many of them come with their original Unyson builder plugin. Deactivating it brought back display of icons.

    0
  • Anders Jäderström

    Im running brizy pro and astra pro and the icons will not show up on the live site. But when i am editing it all look good?

    0
  • Marco Michely

    @Anders Jäderström would you please take a look to the browser dev tools (network panel)? Can you see any errors for loading the .txt icon files there?

    0
  • Malachi Gross

    Because I saw it suggested, I checked the dev tools and I get an error on all icons.

    "Access to XMLHttpRequest has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

    0
  • Anders Jäderström

    I´ve got the tips to deactivate CDN at my webhost. And so i did. After the deactivation the icons where visable again. 

    0
  • Fin Goulding

    I too switched off the CDN at my webhost and now the Icons are showing. But now my site is running slower and page updates are taking an age to propagate.

    Brizy: Can you fix the Icon issue please?

    Thanks. 

    0
  • Marco Michely

    @Stuart Longcroft: Haha. Very funny. The right way is not to use txt files as images because they aren't. So it is the brizy team that have to work on the issue - not the brizy users.

    0
  • Max Power

    Hey guys, 

     

    Found that the issue was due to an out of date theme https://wordpress.org/themes/modernize/

    Install a new theme and activate it to see if this works. 

      

    0
  • Aaron Lim

    I'm having the same problem. Icons will show up in editor and not on live site. Any quick fix?

    0
  • Michelle Jombwe

    I am having the same problem

    Can anyone explain to me in plain-language (novice) how to fix it?

    0
  • Sunil Ramlochan

    Same issue here. The icons were showing up just fine, then they stopped.

    I don't know what triggered it. Please help.

    0
  • Christina Holmstoel

    Brizy, any update on this issue, are you going to change the txt files? I'm having the same problem, my icons are not showing in my Wordpress preview and my site is hosted on GoDaddy. Thank you

    0
  • Marco Michely

    @Alex as i say earlier:

    > The right way is not to use txt files as images because they aren't. So it is the brizy team that have to work on the issue - not the brizy users.

    Do not blame third parties for this problem. Brizy Team must solve this properly. Workarounds are not acceptable.

    0
  • Fin Goulding

    I'm a GoDaddy user and I can confirm that disabling the CDN does fix the issue of viewing Brizy icons. The downside is that you lose all the benefits of the CDN in terms of website performance.

    So, my solution was to stop using Brizy and I bought Elementor Pro. 

    Brizy is easier to use but the icon issue was a dealbreaker for me.

    0

Please sign in to leave a comment.